WordPress 5.8 drops support for Internet Explorer 11 (IE 11).

On the one hand, if WordPress stops supporting a browser, this means that new functions are no longer tested on these browsers and it is also not guaranteed that they will still work optimally on these browsers.
On the other hand, the discontinuation of support also affects parts of existing WordPress core functions. Scripts that generate parts of the WordPress core source code are also updated to exclude browsers that are no longer supported and thus achieve performance advantages. This means that any function that relies on these generated files has a high probability of bugs or no longer working for IE11 users. Last but not least, all bugs reported as part of IE11 issues are no longer fixed.